概要

My Tasks のコマンド バーにある Excel にエクスポートボタンを使うと、現在のタスク一覧を、Excel でそのまま開けるファイルとして保存できます。ステータス レポートの作成、Web パーツにはない方法でのタスクの並べ替え、プロジェクトごとのタスク数の集計、作業負荷のスナップショットの保存などに便利です。

エクスポートされるのは、その時点で一覧に表示されているタスクです。フィルターと並べ替えが反映され、現在表示しているページだけでなく、一覧のすべてのページが対象になります。

エクスポートする方法

  1. 一覧の読み込みが完了するまで待ちます。タスクの読み込み中や、タスクがまったくない場合は、ボタンは使用できません。
  2. 一部のタスクだけが必要な場合は、先にフィルターを適用します。期限メニュー (すべての日付、期限超過、今日、今週) とフィルターパネルを使用します。必要な並べ替えの順序も設定してください。詳しくは、KB10293. My Tasks: フィルター、並べ替え、個人用ビュー設定を参照してください。
  3. コマンド バーで Excel にエクスポートをクリックします。
  4. ブラウザーがファイルをダウンロードします。ブラウザーの設定に応じて、ダウンロード フォルダーに保存されるか、保存先を確認するメッセージが表示されます。
  5. ファイルを Excel で開きます。

コマンド バーの「Excel にエクスポート」ボタン

コマンド バーの「Excel にエクスポート」ボタン

エクスポートされる内容

  • すべてのページ。 一覧に 120 件のタスクがあり、ページ サイズが 20 の場合、ファイルには画面上の 20 件ではなく、120 件すべてが含まれます。
  • フィルターと並べ替えを反映。 期限クイック フィルターとフィルターパネルを適用した後に残るタスクが、現在設定されている並べ替えの順序で含まれます。
  • 列の設定の影響を受けない。 ファイルの列は固定で、ページ上でどの列が表示されているかには左右されません。
  • 除外ステータスは含まれない。 除外ステータス(カンマ区切り) の設定で非表示になるタスクは読み込まれないため、エクスポートされません。詳しくは、KB10298. My Tasks: 除外ステータスとタスク一覧の絞り込みを参照してください。

ファイルの列

列内容
ソースPlanner、To Do、Outlook、SharePoint、Project、Azure DevOps のいずれか
タスク名タスクのタイトル
プロジェクト名プロジェクト、プラン、リスト、サイト
タスクの状態タスクの状態
優先度タスクの優先度
作成日作成日 (ブラウザーの日付形式)
期限期限 (ブラウザーの日付形式)。期限がない場合は空
作成者作成者の名前。To Do と Outlook のタスクでは空
タグタスクのすべてのタグを、セミコロンとスペースで区切って 1 つのセルに表示
URL元のタスクのアドレス

列見出しは、Web パーツの表示言語で出力されます。日付には時刻が含まれず、ブラウザーの地域の形式に従います。そのため、同じタスクでも、あるコンピューターでは 10/16/2026、別のコンピューターでは 16.10.2026 のように表示されることがあります。

ファイル

ファイル名には、エクスポートした日付が含まれます。たとえば、2026 年 10 月 16 日にエクスポートした場合は、my-tasks-2026-10-16.csv になります。

ファイルは、バイト オーダー マーク (BOM) 付きの UTF-8 エンコードの CSV (コンマ区切り値) です。BOM により Excel がファイルを UTF-8 として読み取るため、タスクのタイトルに含まれるキリル文字、中国語、日本語などのラテン文字以外の文字も正しく表示されます。値はコンマで、行は改行で区切られます。コンマ、引用符、改行を含む値は、引用符で囲まれます。

📝 注
ボタンの名前は Excel にエクスポートですが、ファイルは .xlsx ブックではありません。Excel が表として開く CSV ファイルです。Excel で、ファイル > 名前を付けて保存を選択すると、Excel ブックとして保存できます。

Excel でファイルを開く

ダウンロードしたファイルをダブルクリックします。ほとんどの環境では、Excel が列を正しく表示します。

すべてのデータが 1 列にまとまって表示される場合は、Windows の地域設定でリストの区切り文字がセミコロンになっており、Excel がセミコロン区切りを想定しています。その場合は、ファイルを開くのではなく、インポートします。

  1. Excel で空白のブックを開き、データ > テキストまたは CSV からを選択します。
  2. ダウンロードしたファイルを選択します。
  3. プレビューで、区切り記号をコンマに設定し、ファイル元が 65001: Unicode (UTF-8) になっていることを確認します。
  4. 読み込みをクリックします。

❗ 重要
ファイルには、タスクの名前、リンク、その他のデータが含まれます。組織のルールに従って保管および共有してください。エクスポートは、お使いのコンピューター上のブラウザーが行います。Web パーツがファイルをどこかに送信することはありません。

💡 ヒント
Excel でデータを選択して 挿入 > テーブルを選択すると、見出しにフィルターと並べ替えの機能が追加されます。ピボットテーブルを作成すれば、プロジェクト名やタスクの状態ごとのタスク数を集計できます。エクスポートする前に、どのタスクが含まれるかを確認するには、期限超過クイック フィルターを使用します。詳しくは、KB10292. My Tasks: 期限列、期限超過の強調表示、クイック フィルターを参照してください。

ファイルの内容が不完全な場合

ファイルのタスクが想定より少ない場合は、次の点を確認してください。フィルターが有効になっていないか (フィルターアイコンが塗りつぶされている場合や、期限がすべての日付以外になっている場合は、フィルターが有効です)、除外ステータスが設定されていないか、すべてのソースが読み込まれたか。読み込みに失敗したソースはスキップされます。詳しくは、KB10307. My Tasks のタスクが表示されない、または読み込まれないのはなぜですか?を参照してください。画面上の一覧に適用されるページングの設定については、KB10297. My Tasks: ページング、行の制限、自動更新、即時読み込みで説明しています。

注目の記事

誤り訂正とサイズ: 確実に読み取れて印刷できる QR コードを作成する

Vitextra QR Code Generator Web パーツの Error Correction (誤り訂正) と Size (サイズ) の設定のリファレンスです。低、中、Quartile、高の各レベルの意味、データ量とロゴがコードに与える影響、印刷に必要なピクセル数、読み取り距離に応じた印刷サイズ、コードの周囲の余白が重要な理由を説明します。

2026/10/15
QR コードのダウンロードとコピー: PNG、JPEG、SVG、WebP

Vitextra QR Code Generator Web パーツから QR コードを取り出す方法を説明します。PNG、JPEG、SVG、WebP 形式でのダウンロード、300 ~ 4000 ピクセルの画像サイズの設定、クリップボードへのコピー、印刷・ドキュメント・Web に適した形式の選び方を取り上げます。

2026/10/14
ゲスト Wi-Fi の QR コードを作成する方法

Vitextra QR Code Generator Web パーツを使用して、スマートフォンをゲスト Wi-Fi に接続する QR コードを作成する手順を説明します。ネットワーク名、パスワード、暗号化の入力、読み取りやすいコードにする設定、テスト、印刷または SharePoint ページでの公開、パスワード変更時の更新を取り上げます。

2026/10/15

共有